• 您的位置: 紫荷精灵 >> 股票 >> 铁锅战法公式全集
  • 铁锅战法公式全集

  • 作者:admin  来源:原创  日期:2015-4-19 4:54:45
  • ——铁锅炒股

    根据铁锅炒股理念编制公式,这两个公式是选股公式,在条件选股中新建

    MA13:=MA(CLOSE,13);

    MA77:=MA(CLOSE,77);

    MA99:=MA(CLOSE,99);

    CROSS(CLOSE,MA13) and MA77〉REF(MA77,1) and MA99〉REF(MA99,1);

    适用软件:分析家软件

    适用周期:30分钟或60分钟

    以下适用于日线

    MA3:=MA(CLOSE,3);

    MA20:=MA(CLOSE,20);

    MA25:=MA(CLOSE,25);

    CROSS(CLOSE,MA3) and MA20〉REF(MA20,1) and MA25〉REF(MA25,1);


    十三、铁锅战法指标(同花顺) (2008-01-10 22:59:01)

    铁锅MA主图均线: 

    MA$1:MA(CLOSE, N1);
    AA:=MA(C, N1);
    PARTLINE(AA,AA>REF(AA,1),RGB(255,0,0),AA<REF(AA,1),RGB(0,255,0)),LINETHICK1;
    BB:=HHV(AA,G);
    PARTLINE(BB,BB>REF(BB,1),RGB(255,0,0),BB<REF(BB,1),RGB(0,255,0)),LINETHICK1;
    EE:=IF(AA<BB,(AA-(BB-AA)),BB),colorred;
    PARTLINE(EE,EE>REF(EE,1),RGB(255,0,0),EE<REF(EE,1),RGB(0,255,0)),LINETHICK1;
    MA$2:MA(CLOSE, N2);
    PARTLINE(MA$2,MA$2>REF(MA$2,1),RGB(255,255,0),MA$2<REF(MA$2,1),RGB(0,111,211)),LINETHICK1;
    MA$3:MA(CLOSE, N3);
    PARTLINE(MA$3,MA$3>REF(MA$3,1),RGB(222,0,222),MA$3<REF(MA$3,1),RGB(255,255,255)),LINETHICK1;
    MA$4:MA(CLOSE, N4);
    STICKLINE(MA$1>=REF(MA$1,1),MA$1,MA$1,5,1),colorred,LINETHICK4,POINTDOT;
    STICKLINE(MA$1<=REF(MA$1,1),MA$1,MA$1,5,1),colorgreen,LINETHICK4,POINTDOT;
    STICKLINE(REF(MA$2,P)<MA$2,MA$2,REF(MA$2,P),40,1),coloryellow;

    说明:N1 0  1000   10         曲线属性:N1 N2 N3 采样点 N4 实连线
          N2 0  1000   20
          N3 0  1000   60
          N4 0  1000    5
          N5 0  1000    3
          N6 0  1000    0
          N7 0  1000    0
          N8 0  1000    0
          G  0   3      1
          P  0  1000    1

     主图5分/15分/30分/60分设13/77/99这3条线 日线设5/10/20/60线

    铁锅KDJ指标:

    STICKLINE(C>0,80,79,15,0),colorred;
    STICKLINE(C>0,50,49,15,0),colorwhite;
    STICKLINE(C>0,20,19,15,0),colorgreen;
    RSV=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
    a=SMA(RSV,M1,1);
    b=SMA(a,M2,1);
    e=3*a-2*b;
    K:=a;
    K1:=IF(a>=b,a,b);
    PARTLINE(K1,K1>REF(K1,1),RGB(255,0,0),K1<REF(K1,1),RGB(0,255,0)),LINETHICK2;
    D1:=IF(b-a,b,a);
    PARTLINE(D1,D1>REF(D1,1),RGB(255,255,0),D1<REF(D1,1),RGB(0,255,0)),LINETHICK2;
    D:b;
    J:e;
    J1:e;
    STICKLINE(K>D,K,D,8,1),colorred;
    STICKLINE(J>80,80,J,5,0),color00ffff;
    STICKLINE(K1>d1,K1,d1,8,1),colorred;

    说明:

    数值:9  6  3     全周期
    D  采样点  线宽1  颜色23
    J  实连线  线宽1  颜色03
    J1 采样点  线宽3  与用户设定值比较80

     指标KDJ日线设10/5/3分时线设13/5/3

    铁锅MACD指标:
    DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
    DEA  :EMA(DIFF,m);
    PARTLINE(DEA ,DEA >REF(DEA ,1),RGB(255,0,0),DEA <REF(DEA ,1),RGB(0,255,0)),LINETHICK2;
    MACDA:=2*(DIFF-DEA/2);
    MACDB:=MA(MACDA,n);
    STICKLINE(MACDA >0 ,MACDA,0,1,1),colorred;
    STICKLINE(MACDA <0 ,MACDA,0,1,1),colorgreen;
    Zero : 0;
    STICKLINE(dea>DIFF,dea,DIFF,7,1),colorblue;
    STICKLINE(dea<DIFF,dea,DIFF,7,1),coloryellow;
    STICKLINE(MACDA>1*REF(MACDA , 1), MACDA, MACDB ,7, 0),colorFF11FF;
    STICKLINE(MACDA<1*REF(MACDA , 1), MACDA, MACDB ,7, 0),colorbrown;
    STICKLINE(MACDA<=REF(MACDA,1),MACDA,MACDA,5,0),colorgreen,LINETHICK3,POINTDOT;
    STICKLINE(MACDA>=REF(MACDA,1),MACDA,MACDA,5,0),colorred,LINETHICK3,POINTDOT;

    说明:short  0   100  13           属性:DIFF 实连线  1   与用户 0
          long   0   100  34                 DEA  采样点  1    色  04
          m      0   100  13                 ZERO  虚连线 1    色  14
          n      0   100   3
    参数:日线 5  20  5
          分时 13 34  13

     MACD日线设10/20/10 分时里13/77/13 然后把MACD除2: MACD:2*(DIFF-DEA/2)

    主图5分/15分/30分/60分设13/77/99这3条线 日线设5/10/20/60线 指标KDJ日线设10/5/3分时线设13/5/3 MACD日线设10/20/10 分时里13/77/13 然后把MACD除2: MACD:2*(DIFF-DEA/2)

    铁锅布林极限
    上轨:100;
    下轨:-100;
    上极限:170;
    下极限:-170;
    b1:=MA(CLOSE,N);
    布林极限:=100*(CLOSE-b1)/STD(CLOSE,n);
    AA:MA(布林极限,3);
    布林K值:=MA(布林极限,5);
    DD:=SMA(布林K值,n1,1);
    FILLRGN(DD,REF(DD,1),DD>REF(DD,1),RGB(255,0,0),DD<=REF(DD,1),RGB(0,255,0) );
    PARTLINE(DD,DD>REF(DD,1),RGB(255,0,0),DD<REF(DD,1),RGB(0,255,0));
    J:=AA;
    STICKLINE(J>REF(J,1),J,REF(J,1),8,0),COLOR0022FF;
    STICKLINE(J>REF(J,1),HHV(J,3),LLV(J,3),1,0),COLOR0022FF;
    STICKLINE(J>REF(J,1),J,REF(J,1),5,0),COLOR0066FF;
    STICKLINE(J>REF(J,1),J,REF(J,1),3,0),COLOR0099FF;
    STICKLINE(J>REF(J,1),J,REF(J,1),1.5,0),COLOR00DDFF;
    STICKLINE(J>REF(J,1),J,REF(J,1),0,0),COLOR00DDFF;
    STICKLINE(J<REF(J,1),J,REF(J,1),8,0),COLORFF2200;
    STICKLINE(J<REF(J,1),HHV(J,3),LLV(J,3),1,0),COLORFF2200;
    STICKLINE(J<REF(J,1),J,REF(J,1),5,0),COLORFF6600;
    STICKLINE(J<REF(J,1),J,REF(J,1),3,0),COLORFF9900;
    STICKLINE(J<REF(J,1),J,REF(J,1),1.5,0),COLORFFDD00;
    STICKLINE(J<REF(J,1),J,REF(J,1),0,0),COLORFFDD00;

    布林极限参数设置:
    clip_image094
    铁锅BIAS1

    BIAS1:= (CLOSE-MA(CLOSE,N))/MA(CLOSE,N)*100;
    AA:EMA(BIAS1,3);
    MID:MA(AA,N);
    UPPER:MID+ 1.38*STD(AA,N);
    LOWER:MID-1.38*STD(AA,N);
    PARTLINE(AA,AA>REF(AA,1),RGB(255,0,0),AA<REF(AA,1),RGB(0,255,0));
    STICKLINE(AA<=REF(AA,1),AA,AA,1,0),colorgreen,LINETHICK3,POINTDOT;
    STICKLINE(AA>=REF(AA,1),AA,AA,1,0),colorred,LINETHICK3,POINTDOT;
    STICKLINE(AA>0,AA,0,7,1),COLOR0000AA,linethick1;
    STICKLINE(AA<0,AA,0,7,1),COLOR008800,linethick1;

    BIAS1参数设置:
    clip_image096
     

    铁锅MACD 002

    DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

    DEA  : EMA(DIFF,M);

    MACD : 2*(DIFF-DEA/2);

    Zero : 0;

    STICKLINE(MACD<Zero ,MACD,Zero ,2,0),colorgray;

    STICKLINE(MACD>Zero,MACD,Zero,1,0),colorred;

    STICKLINE(MACD>DIFF,MACD,DIFF,6,6),coloryellow,LINETHICK3,POINTDOT;

    STICKLINE(MACD<DIFF,MACD ,DIFF,6,6),colorwhite,LINETHICK3,POINTDOT;

    FILLRGN(DEA,DIFF,(DEA<DIFF),colormagenta);

    FILLRGN(DEA,DIFF,(DEA>DIFF),colorblue);

    STICKLINE(MACD>=REF(MACD,1)AND MACD>DIFF,DIFF,MACD,6,1),colorred,LINETHICK3,POINTDOT;

    STICKLINE(MACD<=REF(MACD,1)AND MACD<DIFF,DIFF,MACD,6,1),colorgreen,LINETHICK3,POINTDOT;

    //趋势:SMA(DEA,SHORT,1);

    //FILLRGN(趋势,REF(趋势,3),趋势>REF(趋势,3),RGB(255,255,0),趋势<=REF(趋势,3),RGB(0,255,255) );

    //PARTLINE(趋势 ,趋势 >REF(趋势,1),RGB(255,255,0),趋势<REF(趋势 ,1),RGB(0,255,255)),LINETHICK1;

    中轨:MA(DEA,p);

    下轨:中轨-1.38*STD(DEA,p);

    上轨:中轨+1.38*STD(DEA,p);

    下极限:中轨-1.58*STD(DEA,p);

    上极限:中轨+1.58*STD(DEA,p);

     说明:MACD日线设10/20/10 分时里13/77/13 然后把MACD除2: MACD:2*(DIFF-DEA/2)

     MACD参数设置:

     clip_image098

     铁锅RSI

     STICKLINE(C>0,65,65.5,15,0),colorred;

    STICKLINE(C>0,50,49.5,15,0),colorred;

    STICKLINE(C>0,51,65,7,1),color909090;

    STICKLINE(C>0,34,35,8,0),coloreeee33;

    LC := REF(CLOSE,1);

    RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;

    MARSI:MA(RSI1,3,1);

    PARTLINE(MARSI,MARSI>REF(MARSI,1),RGB(255,0,0),MARSI<REF(MARSI,1),RGB(0,255,0)),LINETHICK1;

    STICKLINE(MARSI>50 ,MARSI,50,7,1),COLOR0000AA;

    STICKLINE(MARSI<50 ,MARSI,50,7,1),COLOR008800;

    a:SMA(MARSI,5,1);

    STICKLINE(MARSI>=REF(MARSI,1),MARSI,MARSI,5,0),colorred,LINETHICK3,POINTDOT;

    STICKLINE(MARSI<REF(MARSI,1),MARSI,MARSI,5,0),colorgreen,LINETHICK3,POINTDOT;

    PARTLINE(a,a>REF(a,1),RGB(255,0,0),a<REF(a,1),RGB(0,255,0)),LINETHICK2;

    STICKLINE(C>0,34,35,8,0),coloreeee33;

    趋势1:=SMA(a,N1,1);

    FILLRGN(趋势1,REF(趋势1,1),趋势1>REF(趋势1,1),RGB(255,255,0),趋势1<=REF(趋势1,1),RGB(0,88,255) );

    PARTLINE(趋势1,趋势1>REF(趋势1,1),RGB(255,255,0),趋势1<REF(趋势1,1),RGB(0,111,255)),LINETHICK1;

     铁锅RSI参数设置:日线设10\5

    clip_image100

     

     铁锅KDJ002

     STICKLINE(C>0,82,89,1,0),coloree8088;

    STICKLINE(C>0,12,20,1,0),color909090;

    STICKLINE(C>0,50,51,6,1),colorwhite;

    E1:95;

    A1:89;

    B1:82;

    C1:20;

    D1:12;

    F1:5;

    RSV=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

    A=SMA(RSV,5,1);

    b=SMA(A,3,1);

    e=3*A-2*b;

    K:=A;

    D:=b;

    J:e;

    PARTLINE(j,j>REF(j,1),colorred,j<REF(j,1),colorgreen),Linethickl;

    FILLRGN(k,d,k>=d,colorred,k<=d,colorgreen);

    STICKLINE(J>=REF(J,1),J,J,5,0),colorred,LINETHICK4,POINTDOT;

    STICKLINE(J<REF(J,1),J,J,5,0),colorgreen,LINETHICK4,POINTDOT;

    FILLRGN(B1,J,(B1<J),colorblue);

    FILLRGN(A1,J,(A1<J),colorred);

    FILLRGN(J,E1,(E1<J),colorwhite);

    FILLRGN(D1,J,(D1>J),colorblue);

    FILLRGN(F1,J,(F1>J),colorwhite);

     KDJ参数设置:

    clip_image102

    说明:指标KDJ日线设10/5/3分时线设13/5/3

     十四、其它指标:

     铁锅MACD001 (2008-05-02 14:35:41)

     DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
    DEA  :EMA(DIFF,M);
    MACD1 : =2*(DIFF-DEA/2);
    STICKLINE(MACD1 >0 ,MACD1,0,1,1),colorred;
    STICKLINE(MACD1 <0 ,MACD1,0,1,1),colorgreen;
    STICKLINE(C>0,0,0.00001,15,0),colorgreen;
    STICKLINE(MACD1>0,-0.01,0,15,1),colorred;
    STICKLINE(DIFF >DEA ,DEA ,DIFF ,7,1),colorwhite;
    STICKLINE(DIFF <DEA ,DEA ,DIFF ,7,1),colorblue;
    STICKLINE(MACD1>=REF(MACD1,1),MACD1,MACD1,5,0),colorred,LINETHICK3,POINTDOT;
    STICKLINE(MACD1<REF(MACD1,1),MACD1,MACD1,5,0),colorgreen,LINETHICK3,POINTDOT;
    趋势1:=SMA(DEA ,SHORT,1);
    FILLRGN(趋势1,REF(趋势1,1),趋势1>REF(趋势1,1),RGB(0,255,0),趋势1<=REF(趋势1,1),RGB(255,0,0) );
    PARTLINE(趋势1,趋势1>REF(趋势1,1),RGB(0,255,0),趋势1<REF(趋势1,1),RGB(255,0,0)),LINETHICK1;

    说明:short 0   100    13       属性:实连线

      Long  0   100    34

      m     0   100    13

      n     0    5      3

     KDJ001 (2008-05-02 15:22:24)

     STICKLINE(C>0,80,79,15,0),colorred;
    STICKLINE(C>0,50,49,15,0),colorwhite;
    STICKLINE(C>0,20,19,15,0),colorgreen;
    RSV=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
    a=SMA(RSV,M1,1);
    b=SMA(a,M2,1);
    e=3*a-2*b;
    K:=a;
    D:=b;
    J:=e;
    PARTLINE(J,J>REF(J,1),RGB(255,0,0),J<REF(J,1),RGB(0,255,0)),LINETHICK1;
    v1:=IF(a>=b,a,b),LINETHICK1;
    PARTLINE(v1,v1>REF(v1,1),RGB(222,0,222),v1<REF(v1,1),RGB(0,255,255));
    V2:=IF(b-a,b,a),LINETHICK1;
    PARTLINE(V2,V2>REF(V2,1),RGB(222,0,222),v2<REF(V2,1),RGB(0,255,255));
    STICKLINE(K>D,K,D,8,1),colorred;
    STICKLINE(V1>V2,V1,V2,8,1),coloryellow;
    STICKLINE(J>=REF(J,1),J,J,5,0),colorred,LINETHICK3,POINTDOT;
    STICKLINE(J<=REF(J,1),J,J,5,0),colorgreen,LINETHICK3,POINTDOT;
    //STICKLINE(J<=REF(50,1),J,50,1,0),colorgreen;
    //STICKLINE(J>=REF(50,1),J,50,1,0),colorred;
    VARA:=HHV(HIGH,N);
    VARB:=LLV(LOW,N);
    VAR11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
    VAR12:=HHV(VAR11,N)*8;
    底谷区:EMA(IF(LOW<=VARB AND J<20,(VAR11+VAR12),0),3)/618;
    STICKLINE(底谷区>0,0,底谷区*0.6,8,1 ),color00ff00;
    VAR13:=SMA(ABS(H-REF(H,1)),3,1)/SMA(MAX(H-REF(H,1),0),3,1)*100;
    VAR14:=HHV(VAR13,N)*8;
    高峰区:EMA(IF(HIGH>=VARA AND J>80,(VAR13+VAR14),0),3)/618;
    STICKLINE(高峰区>0,0,高峰区*10.6,8,1 ),colorred;
    趋势:=SMA(D,N,1);
    FILLRGN(趋势,REF(趋势,1),趋势>REF(趋势,1),RGB(255,0,0),趋势<=REF(趋势,1),RGB(0,255,0) );
    PARTLINE(趋势,趋势>REF(趋势,1),RGB(255,0,0),趋势<REF(趋势,1),RGB(0,255,0)),Linethick1;

     铁macd002 (2008-05-02 15:25:48)

     DIFF : =EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
    DEA  :=EMA(DIFF,M);
    MACD1 : 2*(DIFF-DEA/2);
    MAA:MA(MACD1,6);
    PARTLINE(MAA,MAA>REF(MAA,1),RGB(255,255,0),MAA<REF(MAA,1),RGB(0,20,255)),LINETHICK2;
    STICKLINE(MACD1 >0 ,MACD1,0,1,1),colorred;
    STICKLINE(MACD1 <0 ,MACD1,0,1,1),colorgreen;
    STICKLINE(MACD1>0,0.00001,0.00003,15,0),colorred;
    STICKLINE(MACD1<0,0.00001,0.00003,15,0),colorgreen;
    STICKLINE(MACD1 >MAA,MACD1,MAA,7,1),colormagenta,LINETHICK1;
    STICKLINE(MACD1 <MAA ,MACD1,MAA,7,1),colorcyan,LINETHICK1;
    AH:=HHV(MACD1,SHORT);
    PARTLINE(AH,AH>REF(AH,1),RGB(255,0,0),AH<REF(AH,1),RGB(0,255,0)),LINETHICK2;
    AL:=LLV(MACD1,SHORT);
    PARTLINE(AL,AL>REF(AL,1),RGB(255,0,255),AL<REF(AL,1),RGB(0,255,0)),LINETHICK2;
    STICKLINE(MACD1>=REF(MACD1,1),MACD1,MACD1,8,0),colorred,LINETHICK2;
    STICKLINE(MACD1<REF(MACD1,1),MACD1,MACD1,8,0),colorgreen,LINETHICK2,POINTDOT; 

     MACD002

     <DIV><FONT face=宋体>DIFF : =EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);<BR>DEA&nbsp; :=EMA(DIFF,M);<BR>MACD1 : 2*(DIFF-DEA/2);<BR>MAA:MA(MACD1,6);<BR>PARTLINE(MAA,MAA&gt;REF(MAA,1),RGB(255,255,0),MAA&lt;REF(MAA,1),RGB(0,20,255)),LINETHICK2;<BR>STICKLINE(MACD1 &gt;0 ,MACD1,0,1,1),colorred;<BR>STICKLINE(MACD1 &lt;0 ,MACD1,0,1,1),colorgreen;<BR>STICKLINE(MACD1&gt;0,0.00001,0.00003,15,0),colorred;<BR>STICKLINE(MACD1&lt;0,0.00001,0.00003,15,0),colorgreen;<BR>STICKLINE(MACD1 &gt;MAA,MACD1,MAA,7,1),colormagenta,LINETHICK1;<BR>STICKLINE(MACD1 &lt;MAA ,MACD1,MAA,7,1),colorcyan,LINETHICK1;<BR>AH:=HHV(MACD1,SHORT);<BR>PARTLINE(AH,AH&gt;REF(AH,1),RGB(255,0,0),AH&lt;REF(AH,1),RGB(0,255,0)),LINETHICK2;<BR>AL:=LLV(MACD1,SHORT);<BR>PARTLINE(AL,AL&gt;REF(AL,1),RGB(255,0,255),AL&lt;REF(AL,1),RGB(0,255,0)),LINETHICK2;<BR>STICKLINE(MACD1&gt;=REF(MACD1,1),MACD1,MACD1,8,0),colorred,LINETHICK2;<BR>STICKLINE(MACD1&lt;REF(MACD1,1),MACD1,MACD1,8,0),colorgreen,LINETHICK2,POINTDOT;</FONT>&nbsp;</DIV>

     铁macd003 (2008-05-02 15:27:23)

     DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
    DEA  : EMA(DIFF,M);
    MACD : 2*(DIFF-DEA/2);
    Zero : 0;

     //DIFF : =EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
    //DEA  : =EMA(DIFF,M);
    //MACD : 2*(DIFF-DEA/2);
    //MACDMA:MA(MACD,5);
    STICKLINE(MACD>DIFF,MACD,DIFF,7,0),colormagenta;
    STICKLINE(MACD<DIFF,MACD,DIFF,7,0),colorgreen;
    趋势:=SMA(dea,short,1);
    FILLRGN(趋势,REF(趋势,1),趋势>REF(趋势,1),RGB(255,0,0),趋势<=REF(趋势,1),RGB(0,0,255) );
    PARTLINE(趋势,趋势>REF(趋势,1),RGB(255,0,0),趋势<REF(趋势,1),RGB(0,0,255)),LINETHICK3;

     铁macd002 (2008-05-02 15:29:37)

     DIFF : =EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);
    DEA  :=EMA(DIFF,M);
    MACD1 : 2*(DIFF-DEA/2);
    MAA:MA(MACD1,6);
    PARTLINE(MAA,MAA>REF(MAA,1),RGB(255,255,0),MAA<REF(MAA,1),RGB(0,20,255)),LINETHICK2;
    STICKLINE(MACD1 >0 ,MACD1,0,1,1),colorred;
    STICKLINE(MACD1 <0 ,MACD1,0,1,1),colorgreen;
    STICKLINE(MACD1>0,0.00001,0.00003,15,0),colorred;
    STICKLINE(MACD1<0,0.00001,0.00003,15,0),colorgreen;
    STICKLINE(MACD1 >MAA,MACD1,MAA,7,1),colormagenta,LINETHICK1;
    STICKLINE(MACD1 <MAA ,MACD1,MAA,7,1),colorcyan,LINETHICK1;
    AH:=HHV(MACD1,SHORT);
    PARTLINE(AH,AH>REF(AH,1),RGB(255,0,0),AH<REF(AH,1),RGB(0,255,0)),LINETHICK2;
    AL:=LLV(MACD1,SHORT);
    PARTLINE(AL,AL>REF(AL,1),RGB(255,0,255),AL<REF(AL,1),RGB(0,255,0)),LINETHICK2;
    STICKLINE(MACD1>=REF(MACD1,1),MACD1,MACD1,8,0),colorred,LINETHICK2;
    STICKLINE(MACD1<REF(MACD1,1),MACD1,MACD1,8,0),colorgreen,LINETHICK2,POINTDOT;

    主图均线01 (2008-05-02 16:57:25)

     MA$1:MA(CLOSE, N1);
    AA:=MA(C, N1);
    PARTLINE(AA,AA>REF(AA,1),RGB(255,0,0),AA<REF(AA,1),RGB(0,255,0)),LINETHICK1;
    BB:=HHV(AA,G);
    PARTLINE(BB,BB>REF(BB,1),RGB(255,0,0),BB<REF(BB,1),RGB(0,255,0)),LINETHICK1;
    EE:=IF(AA<BB,(AA-(BB-AA)),BB),colorred;
    PARTLINE(EE,EE>REF(EE,1),RGB(255,0,0),EE<REF(EE,1),RGB(0,255,0)),LINETHICK1;
    MA$2:MA(CLOSE, N2);
    PARTLINE(MA$2,MA$2>REF(MA$2,1),RGB(255,255,0),MA$2<REF(MA$2,1),RGB(0,111,211)),LINETHICK1;
    MA$3:MA(CLOSE, N3);
    PARTLINE(MA$3,MA$3>REF(MA$3,1),RGB(222,0,222),MA$3<REF(MA$3,1),RGB(255,255,255)),LINETHICK1;
    MA$4:MA(CLOSE, N4);
    STICKLINE(MA$1>=REF(MA$1,1),MA$1,MA$1,5,1),colorred,LINETHICK4,POINTDOT;
    STICKLINE(MA$1<=REF(MA$1,1),MA$1,MA$1,5,1),colorgreen,LINETHICK4,POINTDOT;
    STICKLINE(REF(MA$2,P)<MA$2,MA$2,REF(MA$2,P),40,1),coloryellow;

     说明:N1 0  1000   10         曲线属性:N1 N2 N3 采样点 N4 实连线
          N2 0  1000   20
          N3 0  1000   60
          N4 0  1000    5
          N5 0  1000    3
          N6 0  1000    0
          N7 0  1000    0
          N8 0  1000    0
          G  0   3      1
          P  0  1000    1

  • 上一篇:铁锅战法全集
    下一篇:被疯传十万次的失传的营销秘诀